SP Forms and Content Types

rss

Posted by Katerina - Jul 22 ’14 at 04:59

Hi,

 

I have a list with several content types and I used SP Forms to create a form for each content type. Until now everything works fine. The procedure is to fill a new project request form, which will go for approval. When is approved it sends an email with a link to Specifications Request Form, with the Project Number prepopulated in the form. This works fine as well. The problem comes when the user submits the form. Instead of saving a specification request form on the list it saves a new project request form. Any ideas why this happens?

 Additionally I found out that it has the same issue when you fill the form from a link I have on my homepage.

Thanks 

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 10 months 26 days
    #1 by Dmitry Kozlov Jul 23 ’14 at 06:42

    Hi Katerina,

    You should insert the id of the Specifications Reques into the new from URL which you send by e-mail.

    Example:

    /Lists/Custom/fd_Item_New.aspx?List=fce5ae43%2D52aa%2D4f03%2Daa93%2D667112e7b5ce&Source=http%3A%2F%2Ff2013%2FLists%2FCustom%2FAllItems%2Easpx&ContentTypeId=0x010067C8F3C4D3D2274EAEA7C7494EE6F472&RootFolder=%2FLists%2FCustom

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 10 months 26 days
    #2 by Dmitry Kozlov Jul 23 ’14 at 06:44

    [#1]: /Lists/Custom/fd_Item_New.aspx?List=fce5ae43%2D52aa%2D4f03%2Daa93%2D667112e7b5ce
    &Source=http%3A%2F%2Ff2013%2FLists%2FCustom%2FAllItems%2Easpx
    &ContentTypeId=0x010067C8F3C4D3D2274EAEA7C7494EE6F472
    &RootFolder=%2FLists%2FCustom

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 10 months 26 days
    #3 by Dmitry Kozlov Jul 23 ’14 at 06:45

    [#2]: &ContentTypeId=0x010067C8F3C4D3D2274EAEA7C7494EE6F472

Displaying 1 to 3 of 3 messages