Related Items Issue

rss

Posted by cdcbolton - Nov 4 ’16 at 10:21

Hello

 

Getting some stange behaviour using the 'related items' control. Using a filter to the external list say 'project name' which occurs in  the source list (the form I'm designing) and the target list. There is 1 to Many relationship and I'm displaying the resultant data in a datasheet style view. All works very well in that the matching related items are being displayed but underneath the related items the results are being display 4 more times? So it appears at runtime we have 4 related item controls being displayed. interestingly the data being displayed in the extraneous instances is not the actual related data but data from other 'projects'. I will point out that the target list 'project name' colums is a lookup (to the source list) but is NOT multiple select.

 

Thanks

 

The Configuration Settings for the Related Items

Configuration Dialog

The resultant Display Form:

 

The area in black is correct, but below the form buttons we see the results repeated 3 more times, this data is for other projects in the target list and seems to missing the project columm, the column used to relate the 2 lists?

 

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 22 days
    #1 by Dmitry Kozlov Nov 7 ’16 at 03:03

    Could you provide a screenshot of the form?

  • cdcbolton
    Member
    Member for: 3 years 4 months
    #2 by cdcbolton Nov 9 ’16 at 04:54

    The configuration dialog for the related items

    and the result:

    The area in black is correct but the area in read is repeated 3 times below the close button (the form is in display mode) the amount of times the section is repeated depends on the number of times 'project name' is used in the target table, for instance we have setup entries for 4 projects in total -> 1 correct dataset + 3 redundant datasets displayed.. Notice the redudant 3 extra sets of data are missing the foreign key (project name)?

     

    Thanks in Advance

     

     

  • cdcbolton
    Member
    Member for: 3 years 4 months
    #3 by cdcbolton Nov 9 ’16 at 05:00

    [#2]

  • cdcbolton
    Member
    Member for: 3 years 4 months
    #4 by cdcbolton Nov 9 ’16 at 05:33

    [#3]:

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 22 days
    #5 by Dmitry Kozlov Nov 9 ’16 at 05:46

    [#4]: Have you tried to remove the extra views from the page: switch the page into Edit mode and remove extra web parts? What happens if you remove all related items controls from your form, do extra view disappear as well?

  • cdcbolton
    Member
    Member for: 3 years 4 months
    #6 by cdcbolton Nov 9 ’16 at 10:19

    [#5]: I manually edited and removed the extra web-parts and the issue seems to have gone away. Thanks

Displaying 1 to 6 of 6 messages