Increase the width of text input (for simple text field).

rss

Posted by Дмитрий Фоломеев - Dec 17 ’14 at 03:36

Help me. I can not find on the forum how to change (increase) the width of the text input for simple text field. That is, leave the width of the title constantly and increase only the text input.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 22 days
    #1 by Dmitry Kozlov Dec 17 ’14 at 04:36

    Hi Dmitry,

    Please, take a look at the following thread:

    http://forum.spform.com/forms-designer-for-sharepoint-20/best-way-to-collapse-the-width-of-a-control-25168/

  • Дмитрий Фоломеев
    Дмитрий Фоломеев
    Member
    Member for: 5 years 15 days
    #2 by Дмитрий Фоломеев Dec 17 ’14 at 05:53

    [#1]: Maybe, I did not correctly apply solutions to the forum?

    In the CSS editor I describes a class:

    .your-custom-class {
    width: 700px;
    }

    Next in the Css Class in field Layout: your-custom-class ,
    save and reopen the form..

    The input size of the field does not change.
    How to change the size of the input field? On the form in this tab there are other text fields, the size of the field is the same as the size of other text fields.


  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 22 days
    #3 by Dmitry Kozlov Dec 17 ’14 at 06:06

    [#2]: Dmitry,

    Please, try to define your CSS following way:

    .your-custom-class .ms-long {
      width: 700px;
    }
    
  • Дмитрий Фоломеев
    Дмитрий Фоломеев
    Member
    Member for: 5 years 15 days
    #4 by Дмитрий Фоломеев Dec 17 ’14 at 06:45

    [#3]:

    it does not work, I'll try to give a screenshot..
  • Дмитрий Фоломеев
    Дмитрий Фоломеев
    Member
    Member for: 5 years 15 days
    #5 by Дмитрий Фоломеев Dec 18 ’14 at 03:15

    [#3]:

    Please see the settings in the screenshot.

    https://onedrive.live.com/redir?resid=117A936AF21006E!182&authkey=!APIrl_JTC033zlo&v=3&ithint=photo%2cjpg

    With these settings does not work (SharePoint 2010, field on tab).

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 22 days
    #6 by Dmitry Kozlov Dec 18 ’14 at 03:32

    [#5]: So, please, try to add the !important directive:

    .your-custom-class .ms-long {
      width: 700px !important;
    }
    
  • Дмитрий Фоломеев
    Дмитрий Фоломеев
    Member
    Member for: 5 years 15 days
    #7 by Дмитрий Фоломеев Dec 18 ’14 at 03:59

    [#6]: Thank You, it works!

  • Дмитрий Фоломеев
    Дмитрий Фоломеев
    Member
    Member for: 5 years 15 days
    #8 by Дмитрий Фоломеев Dec 18 ’14 at 07:36

    [#6]:

    Please tell a similar solution for the fields, containing numbers (numeric field).
  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 22 days
    #9 by Dmitry Kozlov Dec 19 ’14 at 10:05

    [#8]: Please, try this:

    .your-custom-class .ms-input {
    	width: 300px;
    }
    
Displaying 1 to 9 of 9 messages