select2 undefined in Cross Site Lookup

rss

Posted by Felix Müller - Jun 17 ’14 at 04:45

Hi,

I put two CrossSiteLookup Columns in a list on s SharePoint 2013 server.

After inserting values in the corresponding lists the drop-down menus are not visible anymore. In the debugger i see following errors:

SCRIPT5007: Für die Eigenschaft "defaults" kann kein Wert abgerufen werden: Das Objekt ist Null oder undefinied

 

select2_locale_de.js, Zeile 7 Zeichen 5

SCRIPT438: Das Objekt unterstützt die Eigenschaft oder Methode "select2" nicht

CrossSiteLookup.js?rev=1_3_2, Zeile 5 Zeichen 40

SCRIPT438: Das Objekt unterstützt die Eigenschaft oder Methode "select2" nicht

 

CrossSiteLookup.js?rev=1_3_2, Zeile 5 Zeichen 40

Is there any fix for that issue?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 8 months 29 days
    #1 by Dmitry Kozlov Jun 17 ’14 at 06:50

    Hello Felix,

    Thank you for your request. First, please, deactivate/activate Cross-site Lookup feature at the site collection level. Next, make sure that you don't have other JS-errors in the browser console. Did you overrirde Request items or Item format templates of your lookup fields?

  • Felix Müller
    Member
    Member for: 5 years 3 months 12 days
    #2 by Felix Müller Jun 17 ’14 at 07:29

    Hello Dmitry,

    thank you for your help. My customer seems to have a solution deployed which uses jQuery 1.9.1 and which uses select2 in a wrong way (https://github.com/ivaynberg/select2/issues/992)

    After deactivate this feature cross site lookup works again.

    Thank you for pointing me in the right direction

     

Displaying 1 to 2 of 2 messages