related-items with multiple users = problems

rss

Posted by Dars - Apr 15 ’16 at 08:59

Hello,

I have one form with the related-items control on it.   One user is starting entering data in the form and also on the related-items control.  The parent field in my related-items list are then set to "blank" until the user really save the form.

In the meantime, someone else open the form to create an entry, the related-items control will show the entry from the other user because the key is still blanked out.

At least if the second user save his record, he's not "grabbing" the record from the first user but still, is there a way to not have the "unassigned" record to not being showed to the second user because it doesn't belong to him?

Thank you.

  • rostislav
    rostislav
    Moderator
    Member for: 6 years 7 months 4 days
    #1 by rostislav Apr 15 ’16 at 10:40

    Please provide some screenshots showing the problem (upload them to, say, Postimage.org).

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 8 years 2 months 19 days
    #2 by Dmitry Kozlov Apr 17 ’16 at 06:41

    I think, I understood the problem. You need to configure filtering of the Related Items control on a new form so that it will return nothing. Ex.: open Data Source Editor, pick Filter by form field and set both Form field and List field to ID.

  • Dars
    Member
    Member for: 5 years 8 months 1 day
    #3 by Dars Apr 19 ’16 at 07:13

    Hello,

    Actually, I do have filtering already enabled.  So here's the step to reproduce and screenshots.

     

    1- I create a new record in my master list.  Enter one line of data for my child list in my form then press enter.  I didn't saved my record yet but the record for the child list is created if I check on another browser and no parent ID is assigned yet because I didn't saved my master record.

    http://s18.postimg.org/8qafypj21/1_First_Record_Press_Enter.png

    http://s18.postimg.org/kkmsa36pl/2_Child_Record_No_Parent_Yet.png

     

    2- On another browser, I create a new record (still didn't saved the record from the first browser session) and we can see "Comments [#1]" displayed because Master ID = blank (not yet created) and Parent ID from child list is still blank

    http://s18.postimg.org/syxtkfid5/3_New_Record.png

    http://s18.postimg.org/nkz1cvsmx/4_Filtering_Enabled.png

    Thank you

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 8 years 2 months 19 days
    #4 by Dmitry Kozlov Apr 19 ’16 at 07:58

    [#3]: Yes, I see. That is why I recommend you to define a filter for the new form that always returns empty result. Say, Form field = ID and List field = ID. Please, makt sure that this filter is applied for the new form only.

  • Dars
    Member
    Member for: 5 years 8 months 1 day
    #5 by Dars Apr 19 ’16 at 08:01

    Oh ok I get it, sorry.

    Thanks again for your help, that should fix the problem and close pretty much all the pending points I had with my evaluation smile

Displaying 1 to 5 of 5 messages