Forms in Document Sets

rss

Posted by Geir Mathisen - Feb 5 ’15 at 09:14

What is the trick to have the Forms Designer customized forms available within a SharePoint Document Set?

I have created customized forms on the list containing the Document Set -content type.

But all view and edit properties functions still display the standard forms.

 

I need this in order to use cascated lookups within a Document Set metadata. This requires a jscript to be included in the edit form. But how to enable the FD form in a Document Set?

Thanks

Geir Mathisen

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 10 months 26 days
    #1 by Dmitry Kozlov Feb 6 ’15 at 04:54

    Hello Geir,

    Custom forms for Document Sets work well in SharePoint on-premises. Please, make sure that you selected Document Set in the content type list in Forms Designer at the upper right corner before you start designing the form.

  • Geir Mathisen
    Geir Mathisen
    Member
    Member for: 5 years 7 months 20 days
    #2 by Geir Mathisen Feb 6 ’15 at 10:51

    Thanks !!

    That was the magic button that I had not yet discovered.

    Can verify that it FD works well with Document Sets in SharePoint Online as well.

    Great product !

    Geir

  • Geir Mathisen
    Geir Mathisen
    Member
    Member for: 5 years 7 months 20 days
    #3 by Geir Mathisen Feb 11 ’15 at 06:25

    A small follow up question on FD-forms used in Document Sets.

    I am having trouble getting the cusstomized NEW form to work when creating a new document set.

    When hitting the Save button, I receive message:

    Sorry, something went wrong

     

    Invalid item data -- missing FileRef.

    Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator. When resetting the New form the default form does not contain Save & Cancel buttons anymore, which ends up in a kind of deadlock situation. Any idea how to make the FD New form work with Document sets?
    Thanks Geir
  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 10 months 26 days
    #4 by Dmitry Kozlov Feb 12 ’15 at 05:46

    [#3]: Hi Geir,

    What version of Forms Designer do you use? You can find it at the right lower corner of the Forms Designer window. Please, try to install the latest version, 2.9.1. Also, you must place Name field onto the New form otherwise users will not be able to create a Document Set.

  • Geir Mathisen
    Geir Mathisen
    Member
    Member for: 5 years 7 months 20 days
    #5 by Geir Mathisen Feb 12 ’15 at 05:51

    FD version is 2.8.10, used in SP Online.

    Name field was included. In its simplest form only the name field was included in the New form.

    Same result.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 10 months 26 days
    #6 by Dmitry Kozlov Feb 12 ’15 at 06:06

    [#5]: Now I get it. Forms Designer for Office 365 doesn't support new forms of Document Sets. You can find the complete list of differences between editions on the following page:

    http://spform.com/documentation/editions-comparison

    I can suggest the following workaround but it restricts default functionality of document sets, say, users will not be redirected into the document set right after creation. Please, open the new form in Forms Designer and replace Name field with HTML-control. Set its CDATA property in False and put the following code into Content property:

    <div class="fd_field " fd_name="FileLeafRef" style="">
         <div class="fd_title" style="width: 150px; float: left; white-space: nowrap; ">Name<span class="ms-formvalidation"> *</span></div>
         <div class="ms-formbody fd_control" fd_type="File" style="margin-left: 160px;" fd_readonly="False">
              <asp:TextBox id="FileLeafRefField" runat="server" CssClass="ms-long" __designer:bind="{ddwrt:DataBind('i','FileLeafRefField','Text','TextChanged','ID',ddwrt:EscapeDelims(string(@ID)),'@FileLeafRef')}" />
         </div>
    </div>
    

    Please, make sure that you apply this solution to the new form only.

  • Geir Mathisen
    Geir Mathisen
    Member
    Member for: 5 years 7 months 20 days
    #7 by Geir Mathisen Feb 12 ’15 at 07:15

    Thanks.

    That worked, and we'll have to live with the two step registration process.

Displaying 1 to 7 of 7 messages