Form is not saving without approver permission?

rss

Posted by Dan_C - Jul 29 ’16 at 03:32

Hello -

There seems to be some kind of conflict between forms designer and a list with create/edit own items permission.

If I remove the forms designer form I can create an item as a user not in the approver group, but if  I have the forms designer form I can't save unless the user is in the approver group.

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #1 by Dan_C Jul 29 ’16 at 03:54

    I believe it has to do with people picker...  I have the field set to only pick from a particular group (the approvers) and this apparently causing some sort of error in forms designer if the user creating the form is not also in the approvers group...

    I'm seeing a message:

    "The control is not available because you do not have the correct permissions." on the people picker field I have limited to select only from the approvers group...?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 10 months 25 days
    #2 by Dmitry Kozlov Aug 1 ’16 at 01:56

    [#1]: Hi,

    We will try to reproduce the issue. For now, could you try to switch the people picker field into the server side rendering mode: in Forms Designer set Render property of the field in Server.

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #3 by Dan_C Aug 1 ’16 at 10:10

    [#2]: That looks like it will resolve it and can be okay when used in combination with fd.field('Internal Name').control()._el().find('a:eq(0)').click();

    Would still much prefer to use the client version though if you all can resolve that issue quickly.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 10 months 25 days
    #4 by Dmitry Kozlov Aug 2 ’16 at 05:40

    [#3]: We have created a list that requires approval, added a user to the Members group, and created an item with a custom form containing a people picker field without any issues. Could you provide a bit more detail on how to reproduce the issue?

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #5 by Dan_C Aug 2 ’16 at 08:29

    [#4]: Change the people picker field to allow selection only from the approvers group in SP.  Then try to create an item in the list as a member who is not part of the approver group.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 10 months 25 days
    #6 by Dmitry Kozlov Aug 3 ’16 at 05:44

    [#5]: I got the same message even in a default form: The control is not available because you do not have the correct permissions.

    Go to the Site settings -> People and Groups -> Approvers -> Settings -> Group settings. Set 'Who can view the membership of the group?' to 'Everyone'.

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #7 by Dan_C Aug 4 ’16 at 10:58

    [#6]: Okay - that is working.

    I did try with "server" render version of people picker without giving everyone the ability to see members of the group and didn't encounter the error but that is an issue outside my concern for now, giving everyone the ability to see the members did resolve the issue.  Thank you.

Displaying 1 to 7 of 7 messages