Edit form "Page not found"

rss

Posted by Ali - Mar 2 ’16 at 12:08

Hi

I have created a simpme list with 2 fields and trying to custimize the look using spfrom, new  and display form works fine but edit form gives error "Page not found"

  • rostislav
    rostislav
    Moderator
    Member for: 4 years 7 months 4 days
    #1 by rostislav Mar 2 ’16 at 06:01

    Can you give us the URL of the edit form that's giving you problems? (Go to the page that says "Page not found", copy-paste us the URL from the browser's address box)

  • Ali
    Member
    Member for: 3 years 9 months 8 days
    #2 by Ali Mar 2 ’16 at 06:58

    [#1]: /Pages/PageNotFoundError.aspx?requestUrl=myurl/projects/test/~list/fd_New%20Project%20Form_EditForm.aspx

     

    highlighted ~list i beleive creating propblem, I can't see this in new and view forms.

  • Ali
    Member
    Member for: 3 years 9 months 8 days
    #3 by Ali Mar 2 ’16 at 07:01

    new and view form urls, these are working fine.

    [#2]: myurl/test/Lists/test%20forms/fd_New%20Project%20Form_DisplayForm.aspx

    myurl/test/Lists/test%20forms/fd_New%20Project%20Form_NewForm.aspx

  • rostislav
    rostislav
    Moderator
    Member for: 4 years 7 months 4 days
    #4 by rostislav Mar 3 ’16 at 05:58

    [#3]:

    You are right, this is a bug we have resolved. Please reinstall Forms Designer and you'll be OK. Otherwise, don't use the Edit button in the ribbon, instead go onto the edit form via list view.

     

    To reinstall Forms Designer in SharePoint Online remove the app and add it again.

    To do it for SharePoint On-premises download the installer and run it.

  • Ali
    Member
    Member for: 3 years 9 months 8 days
    #5 by Ali Mar 7 ’16 at 08:22

    I have removed the app from settings and added again but getting same error again.

    I also tried deleting the lisbray that contains all javascript files but same error.

    I am using chrome and got error that I have to downlaod the app and run from there, now I am running from the desktop but same error.

     

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #6 by Dmitry Kozlov Mar 8 ’16 at 02:28

    [#5]: Hi Ali,

    Could you provide temporary access to the site? If so, please, send the credentials and the direct link to the problem list to [email protected]

  • Thomas Oberle
    Member
    Member for: 3 years 8 months 25 days
    #7 by Thomas Oberle Mar 15 ’16 at 05:39

    I can confirm the problem. We work with the version 3.0.6.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #8 by Dmitry Kozlov Mar 15 ’16 at 05:43

    [#7]: Hi,

    Do you use SharePoint Online or SharePoint on-premises? Have you designed both, Display and Edit forms in Forms Designer? Could you try to re-save both forms (Display and Edit), clear the browser cache and try again?

  • Thomas Oberle
    Member
    Member for: 3 years 8 months 25 days
    #9 by Thomas Oberle Mar 15 ’16 at 07:36

    We use SharePoint Online and Internet Explorer 11.162.

    I design all three states (new, edit, display) individually.

    As recommended, I have cleared the cache and re-saved all three states. Unfortunately, the problem still exists.

    Below is the URL that points from the "Display"-Page to the " Edit "-page:
    https://{mytenant}.sharepoint.com/sites/sb/dp/~list/fd_Angebotsbereich_EditForm.aspx

    The correct URL is the following:
    https://{mytenant}.sharepoint.com/sites/sb/dp/Lists/Angebotsbereiche/fd_Angebotsbereich_EditForm.aspx?ID=11

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #10 by Dmitry Kozlov Mar 15 ’16 at 07:40

    [#9]: Is it possible to provide temporary access to the site? If so, please, share the site with [email protected] and provide the direct link to the Display form.

Displaying 1 to 10 of 14 messages
Previous12