Display Lookup Fields

rss

Posted by kb2020 - Jul 19 ’16 at 04:04

I have a lookup field , and selected "Add a column to show each of these additional fields" whereby  6 additional columns were selected. However the data for these columns are not shown in form when designed with form designer. How can this be fixed ?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #1 by Dmitry Kozlov Jul 20 ’16 at 05:47

    Hi,

    Most likely, you need to add the additional fields into the target content type. Navigate to the List Settings -> select the content type and click "Add from existing site or list columns" link under the list of columns.

  • kb2020
    Member
    Member for: 3 years 4 months 22 days
    #2 by kb2020 Jul 20 ’16 at 07:08

    Hi, the fields are not available there. How is this normally done ?  I have two list, one that was designed by form designer and another which is used to lookup companies. I created a lookup column for the company name, and also selected additional columns under "

    Add a column to show each of these additional fields: "

     

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #3 by Dmitry Kozlov Jul 20 ’16 at 07:38

    [#2]: Then navigate to the content type settings, remove the lookup field from the content type and then add it again. It will be added with all additional fields.

  • kb2020
    Member
    Member for: 3 years 4 months 22 days
    #4 by kb2020 Jul 20 ’16 at 08:36

    I tried everything, still no luck with this at all.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #5 by Dmitry Kozlov Jul 20 ’16 at 10:12

    [#4]: Are you sure that the content type, the form of which you're editing, is listed in the list of content types next to additional fields:

    After re-adding the lookup column to the content type, restart Forms Designer. The additional fields will appear on the left side, in the list of available fields.

  • kb2020
    Member
    Member for: 3 years 4 months 22 days
    #6 by kb2020 Jul 20 ’16 at 10:40

    [#5]: Hi, Yes I am sure. The problem is when I drag those fields to the form designer and save. When the form is opened, only the lookup value is shown, Lookup:Quantity etc etc is not shown. it is just blank.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 2 months 20 days
    #7 by Dmitry Kozlov Jul 20 ’16 at 10:41

    [#6]: Please, note that the additional fields are read-only. You cannot use them on a new form. As for edit forms, they will change after saving only.

  • kb2020
    Member
    Member for: 3 years 4 months 22 days
    #8 by kb2020 Jul 20 ’16 at 10:55

    [#7]: Ok I didnt want to edit those fields, it is purely for reference purposes, for example if I had an invoice number field, when invoice number is selected the associated details are shown instantly, so there is no ambiguity. But i understand what is possible now. Thanks.

Displaying 1 to 8 of 8 messages