CrossSite Lookup to tenant root list

rss

Posted by Dan_C - Aug 17 ’16 at 04:38

Hello - I'm getting invalid URL for a CrossSite Lookup column I'm trying to create to point to a list on the tenant root site.  Any way to get around this?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 10 months 25 days
    #1 by Dmitry Kozlov Aug 18 ’16 at 04:59

    Hi,

    Please, note that Cross-site Lookup supports linking lists within the same site collection only.

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #2 by Dan_C Aug 18 ’16 at 09:45

    [#1]: Ouch...

    Since Rest API is cross site (collection) -- I can't just change the return query manually to target the site collection I want, can I?  No work around possible?

    I'm really trying to make use of a central list.

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #3 by Dan_C Aug 18 ’16 at 10:17

    [#2]: Okay, so the reason I'm trying to do this was we have a list with people in different roles on the tenant root site and I want to pull that into a lookup to then use as a way to restrict changes to people fields in the form to only allow updating with people in specific roles.

    I'm doing that because it seems people fields cannot resolve AD groups to individual people when the field is set to allow People Only and choose from a SharePoint group which contains an AD group.  The reason I want to use an AD group inside a SP group is so that we don't have to manage SP groups on every site collection for changes in the various roles.

    You wouldn't happen to know a workaround through Forms Designer to make the people field be able to resolve members of an AD group individually in a people field restricted to people only in a SP group containing an AD group, would you?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 6 years 10 months 25 days
    #4 by Dmitry Kozlov Aug 19 ’16 at 05:15

    [#3]: According to the thread below, your approach (adding AD group to SP group and restricting picker to the SP group) should work:

    http://sharepoint.stackexchange.com/questions/245/people-picker-and-fltering-by-certain-ad-groups

    Try to switch rendering mode of the people picker control to Server in Forms Designer.

  • Dan_C
    Member
    Member for: 5 years 8 months 20 days
    #5 by Dan_C Aug 19 ’16 at 10:25

    [#4]: Tried that - no go.  :(

Displaying 1 to 5 of 5 messages