Cross Side Lookup read-only

rss

Posted by Andy Weisse - Jul 13 ’15 at 02:20

Hi!

How can I set CrossSide Lookups read-only?

fd.field('name').readonly(true); <- If that doesn't work anymore since the update?

Best regards

Andy

  • rostislav
    rostislav
    Moderator
    Member for: 7 years 11 days
    #1 by rostislav Jul 13 ’15 at 06:23

    Hello,

    It works in the new version the same way it was working before. Are you using the correct internal name? Often these problems arise because of confusion between the title of a field and it's internal name. The internal name is found in the Forms Designer (click on the control -> in the panel on the right hand side under 'Field' you'll see 'InternalName').

  • Andy Weisse
    Member
    Member for: 6 years 11 months 15 days
    #2 by Andy Weisse Jul 13 ’15 at 06:55

    Thanks for your answer! I used the internal names. The problem exists in all lookup fields.

    All fields are readonly, only these not.

  • Andy Weisse
    Member
    Member for: 6 years 11 months 15 days
    #3 by Andy Weisse Jul 13 ’15 at 08:13

    In Firefox it works, but in Explorer not.

  • rostislav
    rostislav
    Moderator
    Member for: 7 years 11 days
    #4 by rostislav Jul 14 ’15 at 04:45

    [#3]:

    What version of Internet Explorer are you using?

  • rostislav
    rostislav
    Moderator
    Member for: 7 years 11 days
    #5 by rostislav Jul 14 ’15 at 09:08

    [#3]:

    Indeed this is a bug of the new version. We'll fix it in the nearest future. For now please use a workaround:

    Plumsail.CSL.jQuery(fd.field("INTERNALNAME").control()._el().find(".plumsail-csl > input")).select2('enable', false);
    

    Replace last false with true if you want to enable the control.

  • rostislav
    rostislav
    Moderator
    Member for: 7 years 11 days
    #6 by rostislav Jul 15 ’15 at 08:51

    [#3]:

    We've fixed the bug, you can download the latest version from the website and get rid of the workaround.

Displaying 1 to 6 of 6 messages