Blank Page (Page limit?)

rss

Posted by Karlostavitch - Sep 1 ’16 at 11:57

Hi,

This has happened a couple of times now, the first time I undid my css labelling to fix it but then after I added 3 more field it happened again.

The first time the page loads successfully, then any subsequent attempt to load the page it appears blank, no errors, just empty as if its not even attempting to load the page.

Is there a page size / complexity limit? I know Sharepoint referes to a page limit of 25 web parts, is it possible for the SPForm to breach that limmit and be disabled?

  • Karlostavitch
    Member
    Member for: 3 years 26 days
    #1 by Karlostavitch Sep 2 ’16 at 12:14

    Strangely it fixed itself after removing a ; from my javascript, which I should have removed and caused the page to crash, then I added the ; again and now its working fine. So I effectively changed absolutely nothing but its working again.

     

    Maybe a bug?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 11 months 29 days
    #2 by Dmitry Kozlov Sep 2 ’16 at 02:43

    [#1]: Possibly, the form had not been saved yet when you opened it in the browser.

  • Karlostavitch
    Member
    Member for: 3 years 26 days
    #3 by Karlostavitch Sep 20 ’16 at 07:03

    [#2]: This issue was present for a few hours at one point, but since then we have been getting some other issue intermittently.

    Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web server administrator.

    Correlation ID:c499a59d-909c-3000-a30c-bacc82c366fd TypeError: r is not a function TypeError: r is not a function TypeError: r is not a function TypeError: r is not a function - We have been troubleshooting the issue with MS at first, since they wouldn't give us the correlation ID logs and this is SharePoint online, they have said its a query issue. We also had some of our own jquery inserted into the aspx page, a significant amount,  and so we have exported the form from forms designer, then deleted the old forms from Sharepoint Designer and then imported the form back again into Forms Designer and created the edit page from that. the edit page was renamed to docsethomepage.aspx and copied to the document set content type welcome page location. The error was more difficult to produce, but we again recieved the same error, without any of our customised javascript in the aspx page and very little script in the form - see below for grid view (otherwise default spform design :- //Set the Claim number field in each new variation created fd.populateFieldsInGrid($('.related-items'), { The_x0020_Claim_x0020_Number: GetUrlKeyValue('ID'), }); //For document web part fd.updateDroppedDocuments('.related-docs', { Event: GetUrlKeyValue('ID') }); Any advise appreciated.
  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 11 months 29 days
    #4 by Dmitry Kozlov Sep 20 ’16 at 08:00

    [#3]: Are you getting the error while loading the form? Could you send a screenshot and HTML-source of the page to [email protected]?

  • Karlostavitch
    Member
    Member for: 3 years 26 days
    #5 by Karlostavitch Sep 20 ’16 at 08:05

    [#4]: yes its while loading the form, or after saving, when its reloading..

  • Karlostavitch
    Member
    Member for: 3 years 26 days
    #6 by Karlostavitch Nov 3 ’16 at 02:35

    [#5]: The issue was caused because we can have a maximum of 70 editable fields in a single form. So I have changed some of the fields to read-only as per your advice.

Displaying 1 to 6 of 6 messages