Availability of Forms Designer on Saturdays and Sundays

rss

Posted by srallen4 - Jan 13 ’14 at 08:59

We were unable to use the Forms Designer at all this past Saturday and Sunday.  We received an error during the license check, it said "Remote server not available." I've noticed this on a few weekends.

If you are taking your servers down for maintenance, could you provide an alternate method of checking for the license?

Not being able to validate the license causes a slowdown in production for us. The weekend is often the best opportunity we have of doing major forms modifications as most users are not there.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 8 years 4 months 2 days
    #1 by Dmitry Kozlov Jan 13 ’14 at 09:06

    Hello,

    Which version of Forms Designer do you use: on-premise or online? Forms Designer for SharePoint 2013 on-premise doesn't use any external servers to check license or for other reasons. So, I can recommend you to re-install Forms Designer on your farm.

  • srallen4
    Member
    Member for: 8 years 3 months 8 days
    #2 by srallen4 Jan 13 ’14 at 09:14

    We use it on premises.  Saturday (all day) there was an error reporting the remote server was unavailable.   Sunday (all day) there was an error reporting the remote server was unavailable.  Monday morning the forms designer is working as normal. There were no changes on our server this weekend.

    I did not take a screen shot, but I am 100% certain that it said the remote server is unavailable.

    The error is during the license check and only happens on the weekend. How can that be an installation problem?

  • srallen4
    Member
    Member for: 8 years 3 months 8 days
    #3 by srallen4 Jan 13 ’14 at 09:16

    If we reinstall, will this have any impact on the forms that are in production?  Also why is our installation checking a remote server?

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 8 years 4 months 2 days
    #4 by Dmitry Kozlov Jan 13 ’14 at 09:26

    [#2]: The only service Forms Designer uses is located locally in the same farm: /_vti_bin/FormsDesigner/FDService.svc. You can check all requests with fiddler or any other tool which monitors network activity. It is possible that one of your WFE-servers was unavailable, for example. Please, try to make IISRESET on all WFE-servers of your farm when the issue occurs again.  You can contact us by e-mail even on weekends: [email protected] I am sure we can help you to solve this problem if you provide the temporary access to your farm.

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 8 years 4 months 2 days
    #5 by Dmitry Kozlov Jan 13 ’14 at 09:28

    [#3]: All designed forms will continue working properly after re-installation.

Displaying 1 to 5 of 5 messages