A Web Part or Web Form Control on this Page cannot be displayed or imported.

rss

Posted by RMIC - Mar 21 ’16 at 06:09

Hello,

I have install SP-Form on a SP-Server 2013 Enterprise. After creating forms following error after storage appears:

Microsoft.SharePoint.ApplicationRuntime.SafeControls+UnsafeControlException: A Web Part or Web Form Control on this Page cannot be displayed or imported. The type FormsDesigner.Sharepoint.FDDataFormWebPart, FormsDesigner.Sharepoint, Version=2.0.0.0, Culture=neutral, PublicKeyToken=xxxxxxxxxxxxxxxx1 could not be found or it is not registered as safe.

at Microsoft.SharePoint.WebPartPages.WebPartImporter.CreateWebPart(Boolean clearConnections)

at Microsoft.SharePoint.WebPartPages.WebPartImporter.Import(SPWebPartManager manager, XmlReader reader, Boolean clearConnections, Uri webPartPageUri, SPWeb spWeb)

at Microsoft.SharePoint.WebPartPages.WebPartImporter.Import(SPWebPartManager manager, XmlReader reader, Boolean clearConnections, SPWeb spWeb)

at Microsoft.SharePoint.WebPartPages.SPWebPartManager.ImportWebPart(XmlReader reader, String& errorMessage)

at KU1ePbCsORvPBJWkCV.nDhiy0Gna94YOmvBju.jKamFDHjX(SPLimitedWebPartManager  , String  , Int32  , XDocument  , String  )

at KU1ePbCsORvPBJWkCV.nDhiy0Gna94YOmvBju.RZJcDVqPM(SPLimitedWebPartManager  , String  , Forms  , XDocument  )

at CapoZa6QCtaSyS4FGh.F3MnB1ueuj07vhiwCW.GLmAJNxaD(Guid  , Forms  , XDocument  )

at CapoZa6QCtaSyS4FGh.F3MnB1ueuj07vhiwCW.Cr5iwpUJ6(Guid  , Forms  , XDocument  )

 

at FormsDesigner.Sharepoint.FDService.PublishForms(Guid listId, String contentTypeId, Guid groupId, Forms forms, String layout, ServiceFault& fault)

 

I have re-deploy (in Central-Administration) the Forms-Designer and IISReset on the SP-Server.

But it does not help.

Can you please help me?

 

 

  • rostislav
    rostislav
    Moderator
    Member for: 4 years 4 months 15 days
    #1 by rostislav Mar 21 ’16 at 09:08

    Can you describe the exact steps I need to take to reproduce this issue?

  • RMIC
    Member
    Member for: 4 years 4 months 11 days
    #2 by RMIC Mar 21 ’16 at 09:58

    - install SP-Form

    - activate SP-Form in Website Collection

    - create forms in SP-Form

    - save the form - get error (A Web Part or Web Form Control on this Page cannot be displayed or imported...)

    - re-deploy the Forms-Designer (in Central Adminsitration-> System Settings -> Manage farm solutions)

    - IISReset on the SP-Server

  • Dmitry Kozlov
    Dmitry Kozlov
    Admin
    Member for: 5 years 11 months 29 days
    #3 by Dmitry Kozlov Mar 21 ’16 at 11:08

    [#2]: Please, ensure that the package is deployed to the current web application: go to the Central administration -> System settings -> Manage farm solutions -> deploy Plumsail.FormsDesigner2013.wsp globally.

  • Siza
    Member
    Member for: 2 years 3 months 4 days
    #4 by Siza Jun 17 ’17 at 06:31

    I downloaded a trial version (v3.1.3) and am having the same problem. I tried to retract the solution via CA (and it would show Retracting for a while). I had to cancel the retraction (and it would go back to Deployed) and tried via Powershell commands. I get an error that the Retraction job is still running. I can't find this Job in CA (Scheduled/Running/etc).

    I had used the Setup app to install it (this timed-out but was able to deploy the solution from CA). I am using a domain account that is a member of a Sharepoint Farm Admins. I tried using the original Farm Account and this for some reason appears to not have enough farm Account priviledges, even though I have double-checked all these.

    Running Setup and choosing Remove indicates no locations where the Forms Designer is activated. So this does not help either.

    In shot, I can't remove the solution nor can I use it. Anybody seen this issue?

     

  • Siza
    Member
    Member for: 2 years 3 months 4 days
    #5 by Siza Jun 17 ’17 at 07:26

    [#4]: Forgot to add that this is on Sharepoint Server 2013.

Displaying 1 to 5 of 5 messages